您的位置:首页 > 理论基础 > 计算机网络

2015 网络赛

2015-09-20 19:53 337 查看


Fractal

时间限制:1000ms
单点时限:1000ms
内存限制:256MB


描述



This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:
1. Put four points A0(0,0), B0(0,1),
C0(1,1), D0(1,0) on a cartesian coordinate
system.
2. Link A0B0,
B0C0, C0D0,
D0A0 separately, forming square A0B0C0D0.
3. Assume we have already generated square AiBiCiDi,
then square Ai+1Bi+1Ci+1Di+1 is
generated by linking the midpoints of AiBi,
BiCi, CiDi and
DiAi successively.
4. Repeat step three 1000 times.
Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line
and the original logo.


输入

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.
Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the
logo.


输出

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

样例输入
3
0.375
0.001
0.478


样例输出
-1
4
20


#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>

using namespace std;

#define N 1000 + 10
#define M 50
double a
;

double mul_pow(double x, int k)
{
    double res = 1.0;
    while(k)
    {
        if(k & 1) res *= x;
        x = x * x;
        k >>= 1;
    }
    return res;
}

int init()
{
    for(int i = 1; i <= M; i++)
    {
        a[i] = 0.5 - 0.5 * mul_pow(0.5, i - 1);
    }
    cout << a[M - 1] << endl;
    cout << a[M] << endl;
}

int main()
{
    init();
    int T;
    scanf("%d", &T);
    double x;
    while(T--)
    {
        scanf("%lf", &x);
        if(x == 0.5) printf("2004\n");
        else
        {
            int ans = lower_bound(a + 1, a + M, x) - a;

            if(a[ans] == x) printf("-1\n");
            else
            {
                printf("%d\n", (ans - 1) * 4);
            }
        }
    }
    return 0;
}

/*

10
0.375
0.001
0.478

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: