您的位置:首页 > 产品设计 > UI/UE

poj 2031--Building a Space Station(prim)

2015-09-20 11:09 405 查看
Building a Space Station

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 6064Accepted: 3015
Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n

x1 y1 z1 r1

x2 y2 z2 r2

...

xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

/*一个最小生成树问题,prim或者克鲁斯卡尔都可以,题意就是说,空间中有很多细胞
现在让你算一下将这些细胞从表面连起来的最短路径,如果细胞相接触的话就不需要再连,本来我还想过
细胞互相包含的情况,但是没有写进去就过了,可能是题意理解得不好吧,或者就是测试数据太垃圾
一定是这样  0.0||*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int n,vis[1010];
double map[1010][1010],sum;
double x[1010],y[1010],z[1010],r[1010];
double dis(int i,int j)
{
return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])+(z[i]-z[j])*(z[i]-z[j]));
}
void prim()
{
int i,j,p;
double min;
p=-1;
for(i=0;i<n;i++)
{
min=INF;
for(j=1;j<n;j++)
{
if(map[0][j]<min&&!vis[j])
{
min=map[0][j];
p=j;
}
}
if(min==INF) break;
sum+=map[0][p];
vis[p]=1;
for(j=1;j<n;j++)
{
if(map[0][j]>map[p][j])
map[0][j]=map[p][j];
}
}
}
int main()
{
while(scanf("%d",&n),n)
{
memset(vis,0,sizeof(vis));
sum=0;
memset(map,INF,sizeof(map));
int i,j,k;
for(i=0;i<n;i++)
scanf("%lf%lf%lf%lf",&x[i],&y[i],&z[i],&r[i]);
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
{
if(dis(i,j)-r[i]-r[j]>0)
map[i][j]=map[j][i]=dis(i,j)-r[i]-r[j];
else map[i][j]=map[j][i]=0;
}
prim();
printf("%.3lf\n",sum);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: