您的位置:首页 > 产品设计 > UI/UE

hdu 1503 Advanced Fruits(最长公共子序列的应用)

2015-09-19 20:34 477 查看
题目:http://acm.hdu.edu.cn/showproblem.php?pid=1503

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2134 Accepted Submission(s): 1088

Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit
emerges that tastes like a mixture between both of them.

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.



Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.



Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.



Sample Input
apple peach
ananas banana
pear peach




Sample Output
appleach
bananas
pearch


分析:大意,寻找包含两个字符串所有单个字符的最短字符串。



联想到最长公共子序列,输出那个寻找最长公共子序列的路径就是最小的最大串。

处理好边界,第0行全部指向左边,第0列全部指向上边,这样使得最终的汇聚点是(0,0),也就是递归输出的终止点。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=105;
char s1[maxn],s2[maxn];
int dp[maxn][maxn],pre[maxn][maxn];
int len1,len2;
void LCS(){
     memset(dp,0,sizeof(dp));
     memset(pre,0,sizeof(pre));
     len1=strlen(s1+1);
     len2=strlen(s2+1);
     for(int i=1;i<=len1;i++){
        for(int j=1;j<=len2;j++){
            if(s1[i]==s2[j]){
                dp[i][j]=dp[i-1][j-1]+1;
                pre[i][j]=1; //left:0; left-above:1; above:2;
            }
            else if(dp[i-1][j]>dp[i][j-1]){
                dp[i][j]=dp[i-1][j];
                pre[i][j]=2;
            }
            else {
                dp[i][j]=dp[i][j-1];
                pre[i][j]=0;
            }
        }
     }
}
void print(int x,int y){
    if(x==0&&y==0) return ;
    if(pre[x][y]==0) {  print(x,y-1); printf("%c",s2[y]); }
    else if(pre[x][y]==1){ print(x-1,y-1); printf("%c",s1[x]); }
    else {  print(x-1,y); printf("%c",s1[x]);  }
}
int main()
{
    //freopen("cin.txt","r",stdin);
    while(~scanf("%s%s",s1+1,s2+1)){
        LCS();
        for(int i=1;i<=len2;i++) pre[0][i]=0; //边界处理很重要
        for(int i=1;i<=len1;i++) pre[i][0]=2;
        int i=len1,j=len2,top=0;
        char ans[maxn];
        print(len1,len2);
        puts("");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: