您的位置:首页 > 其它

hdu1074Doing Homework(状态压缩,好题)

2015-09-17 20:42 260 查看

Doing Homework

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6601 Accepted Submission(s): 2843


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.



Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.



Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3




Sample Output
2
Computer
Math
English
3
Computer
English
Math

Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

本题是不需要知道起点的状态压缩,而且有输出字典序升序的要求
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
int count1[1<<16][16];
struct node{
    int end1,cost;
    char s[101];
}line[16];

struct Node{
    int num;
    int time;
    int pre;
    int count_;
}dp[1<<16];

int main(){
    int t;
    int n;
    scanf("%d",&t);
    while(t--){
        mem0(dp);
        scanf("%d",&n);
        for(int i=0;i<(1<<n);i++)
            dp[i].num=INF;
        for(int i=0;i<n;i++)
            scanf("%s%d%d",line[i].s,&line[i].end1,&line[i].cost);
        dp[0].num=0;
        for(int s=1;s<(1<<n);s++)
            for(int i=n-1;i>=0;i--)
               if(s&(1<<i)){
                    int tmp=s^(1<<i);
                    int x=dp[tmp].time+line[i].cost-line[i].end1;
                    //printf("i is %d s is %d\n",i,s);
                    //printf("%d\n",x);
                    if(x<=0)
                        x=0;
                    if(x+dp[tmp].num<dp[s].num){
                        dp[s].num=x+dp[tmp].num;
                        dp[s].time=dp[tmp].time+line[i].cost;
                        dp[s].pre=tmp;
                        dp[s].count_=i;
                        /*if(s==((1<<n)-1)){
                            printf("%d\n",x);
                            printf("%d\n",dp[s].num);
                        }*/
                    }
                }
        printf("%d\n",dp[(1<<n)-1].num);
        int cnt=0;
        stack<int>s;
        for(int i=(1<<n)-1;cnt<n;i=dp[i].pre){
            s.push(dp[i].count_);
            cnt++;
        }
        while(!s.empty()){
            printf("%s\n",line[s.top()].s);
            s.pop();
        }
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: