您的位置:首页 > 其它

杭电1212Big Number

2015-09-16 23:58 267 查看


Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6135    Accepted Submission(s): 4290


Problem Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

 

Output

For each test case, you have to ouput the result of A mod B.

 

Sample Input

2 3
12 7
152455856554521 3250

 

Sample Output

2
5
1521

 

Author

Ignatius.L

 
题目要求,前边的数对后边数取余,其实只要不断取余就行了,不需要大数除法的模拟。
附代码:
#include<stdio.h>
#include<string.h>
char c[1100];
long i,j,k,l,m,n;
int main()
{
while(scanf("%s%d",c,&n)!=EOF)
{
l=strlen(c);
m=0;
for(i=0;i<l;i++)
{
m=m*10+c[i]-'0';
m=m%n;
}
printf("%ld\n",m);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 数学