您的位置:首页 > 其它

hdu 1045 Fire Net(dfs)

2015-09-16 15:47 429 查看

Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8239 Accepted Submission(s):
4734


[align=left]Problem Description[/align]
Suppose that we have a square city with straight
streets. A map of a city is a square board with n rows and n columns, each
representing a street or a piece of wall.

A blockhouse is a small castle
that has four openings through which to shoot. The four openings are facing
North, East, South, and West, respectively. There will be one machine gun
shooting through each opening.

Here we assume that a bullet is so
powerful that it can run across any distance and destroy a blockhouse on its
way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that
no two can destroy each other. A configuration of blockhouses is legal provided
that no two blockhouses are on the same horizontal row or vertical column in a
map unless there is at least one wall separating them. In this problem we will
consider small square cities (at most 4x4) that contain walls through which
bullets cannot run through.

The following image shows five pictures of
the same board. The first picture is the empty board, the second and third
pictures show legal configurations, and the fourth and fifth pictures show
illegal configurations. For this board, the maximum number of blockhouses in a
legal configuration is 5; the second picture shows one way to do it, but there
are several other ways.



Your
task is to write a program that, given a description of a map, calculates the
maximum number of blockhouses that can be placed in the city in a legal
configuration.

[align=left]Input[/align]
The input file contains one or more map descriptions,
followed by a line containing the number 0 that signals the end of the file.
Each map description begins with a line containing a positive integer n that is
the size of the city; n will be at most 4. The next n lines each describe one
row of the map, with a '.' indicating an open space and an uppercase 'X'
indicating a wall. There are no spaces in the input file.

[align=left]Output[/align]
For each test case, output one line containing the
maximum number of blockhouses that can be placed in the city in a legal
configuration.

[align=left]Sample Input[/align]

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


[align=left]Sample Output[/align]

5

1

5

2
4

[align=left]Source[/align]
Zhejiang
University Local Contest 2001

[align=left]Recommend[/align]
We have carefully selected several similar problems for
you: 1051 1067 1258 1053 1052

一道搜索题,因为数据很小,最大为4,所以可以直接深搜枚举,还是很不习惯写深搜,想了很久,最后参照别人的代码写的。

题意:与八皇后类似,炮台不能存在于同行同列,除非中间隔墙。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int n,s;
char map[105][105];
int can(int x,int y)
{
int i;
for(i=x-1; i>=0; i--)
{
if(map[i][y]=='X')  //若出现墙,则可以直接跳出
break;
else if(map[i][y]=='K')
return 0;
}
for(i=y-1; i>=0; i--)
{
if(map[x][i]=='X')
break;
else if(map[x][i]=='K')
return 0;
}
return 1;
}
void DFS(int y,int count)
{
int i,j;
if(count>s) //某一种方法的最大炮台数赋给s保存
s=count;
for(i=y; i<n; i++)   //每一行都要搜索
for(j=0; j<n; j++)
{
if(map[i][j]=='.'&&can(i,j)) //can函数判断这个炮台是否能存在
{
map[i][j]='K';  //放了炮台的标记为K
count++;
DFS(i,count); //进入下一次循环
count=0;
map[i][j]='.';
}
}
}
int main()
{
while(~scanf("%d",&n)&&n)
{
for(int i=0; i<n; i++)
scanf("%s",map[i]);   //输入地图
s=0;
DFS(0,0);     //第0行开始搜,炮台数量s初始化为0
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: