您的位置:首页 > 其它

hdu1160FatMouse's Speed DP

2015-09-15 21:41 323 查看
Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.



Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.



Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must
be the case that

W[m[1]] < W[m[2]] < ... < W[m
]

and

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.



Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900




Sample Output

4
4
5
9
7




超级易懂的题意 然而做了一天 状态快快调整啊啊啊啊啊 改了一天都没有debug成功 mark一下以后再说吧

AC的

#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAXN 1000
struct Node
{
    int w,s;//重量和速度 
    int index;//最初的序号,避免排序后乱掉顺序,后面需要输出的 
}mouse[MAXN+10];
bool cmp(Node a,Node b)//先按照w从小到大排序,再按照y从大到小排序 
{
    if(a.w<b.w)  return 1;
    else if(a.w==b.w&&a.s>b.s)return 1;
    else return 0;
}    
int dp[MAXN+10];//dp[i]表示以第i个数据结尾的符合要求的子列长度
int pre[MAXN+10];//记录i对应的上一个数据
int res[MAXN+10];//存放最终结果下标 
int main()
{
    //freopen("test.in","r",stdin);
    //freopen("test.out","w",stdout);
    int i=1,j;
    while(scanf("%d%d",&mouse[i].w,&mouse[i].s)!=EOF)
    {
        dp[i]=1;
        pre[i]=0;
        mouse[i].index=i;
        i++;
    }    
    int n=i-1;
    sort(mouse+1,mouse+1+n,cmp);
    int maxlen=0;//最长序列长度 
    int maxi;//最长序列的最后一个数下标 
    dp[1]=1;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<i;j++)
            if(mouse[i].w>mouse[j].w&&mouse[i].s<mouse[j].s&&dp[j]+1>dp[i])
            {
                 dp[i]=dp[j]+1;
                 pre[i]=j;
                 if(dp[i]>maxlen)
                 {
                       maxi=i;
                       maxlen=dp[i];                      
                 }    
            }                 
    }
    int t=maxi;
    i=0;
    while(t!=0)
    {
        res[i++]=t;
        t=pre[t];
    } 
    printf("%d\n",i);
    while(i>0)
    {
        i--;
        printf("%d\n",mouse[res[i]].index);
    }  
    return 0;             
}


WA的

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct mice
{
    int weight,speed,rank;
}num[1010];
bool cmp(mice a,mice b)
{
    if(a.weight!=b.weight) return a.weight<b.weight;
    return a.speed>b.speed;
}
int dp[1010];
int row[1010],res[1010];
int main()
{
    //freopen("cin.txt","r",stdin);
    int total=1;
    while(~scanf("%d%d",&num[total].weight,&num[total].speed))
    {
        num[total].rank=total++;
    }
    sort(num+1,num+total,cmp);///
    //for(int i=1;i<total;i++) printf("%d  ",num[i].weight);
    for(int i=0;i<=total;i++) dp[i]=1;
    memset(row,0,sizeof(row));
    for(int i=1;i<total;i++)
        for(int j=1;j<i;j++)
        {
            if(num[i].weight>num[j].weight&&num[i].speed<num[j].speed&&dp[i]<dp[j]+1)///
             {
                  dp[i]=dp[j]+1;
                  row[i]=j;
             }///
        }
    int end=1;
    int maxn=0;
    for(int i=2;i<total;i++)
        if(maxn<dp[i])
        {
            maxn=dp[i];
            end=i;
        }
    int t=end;
    int k=0;
    while(t!=0)
    {
        res[k++]=t;
        t=row[t];
    }
    printf("%d\n",k);
    while(k>0)
    {
        k--;
        printf("%d\n",num[res[k]].rank);

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: