您的位置:首页 > 其它

POJ 2431 Expedition (汽车加油问题,STL_优先队列+贪心) (挑战程序P76)

2015-09-15 21:11 351 查看
Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P
Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10

Sample Output
2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题目大意:

有n个加油站,每个加油站的加油的油量有限,距离终点都有一个距离。

一个卡车的油箱无限,没走一个单元要消耗一单元的油,问卡车到达终点的最少加多少次油。

解题思路:

贪心。。。。。卡车走得越远越好,要是不能到达终点,就选择经过的油站里面,加油量最多的加油,然后继续。

所以先按照加油站距离终点的距离,从大到小排列。

利用优先队列来存经过的加油站,根据加油站加油的油量多少排序。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
using namespace std;
const int maxn=1e4+100;
typedef pair<int,int>node;
node a[maxn];
int main()
{
priority_queue<int>qq;
int n,l,p,i,j,sum,ans,ok;
ok=1;
cin>>n;
for(i=0;i<n;i++) cin>>a[i].first>>a[i].second;
cin>>l>>p;
for(i=0;i<n;i++) a[i].first=l-a[i].first;
sum=p;
ans=0;
sort(a,a+n);
a
.first=l;
a
.second=0;
for(i=0;i<=n;i++) {
if(sum>=a[i].first) qq.push(a[i].second);
else {
while(!qq.empty()) {
sum+=qq.top();
qq.pop();
ans++;
if(sum>=a[i].first) break;
}
if(sum<a[i].first) {
ok=0;
break;
}
qq.push(a[i].second);
}
}
if(ok) cout<<ans<<endl;
else cout<<"-1"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: