您的位置:首页 > 其它

zoj 3471 Most Powerful(状态压缩dp)

2015-09-15 13:46 471 查看
Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.


Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.


Output

Output the maximal power these N atoms can produce in a line for each case.


Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0


Sample Output

4
22


枚举所有的状态,0表示存在,1表示不存在(已经与别的气球产生能量并且消失)。然后就是枚举所有的状态(第一个for循环),再在里面两重循环i和j,i表示不消失的那个,j表示消失的那个气球,得到了一个新的状态newS=S+(1<<j),最后就是dp[newS]=max(dp[newS],dp[S]+mp[i][j]); 边界条件是dp[S]=0, 注意这些条件(1、if(S&(1<<i)) continue; 2、if(i==j)continue; 3、if(S&(1<<j)) continue;)

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<queue>
#include<set>
#include<bitset>
#include<map>
#include<vector>
#include<stdlib.h>
using namespace std;
#define max(a,b) (a) > (b) ? (a) : (b)
#define min(a,b) (a) < (b) ? (a) : (b)
#define ll long long
#define eps 1e-10
#define MOD 1000000007
#define N 16
#define M 1<<N
#define inf 1e12
int n;
int mp

;
int dp[M];
int main()
{
while(scanf("%d",&n)==1){
if(n==0) break;
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
scanf("%d",&mp[i][j]);
}
}

memset(dp,0,sizeof(dp));
for(int S=0;S<(1<<n);S++){
for(int i=0;i<n;i++){
if(S&(1<<i)) continue;
for(int j=0;j<n;j++){
if(i==j) continue;
if(S&(1<<j)) continue;
int newS=S+(1<<j);
dp[newS]=max(dp[newS],dp[S]+mp[i][j]);
}
}
}
int ans=0;
for(int i=0;i<(1<<n);i++){
ans=max(ans,dp[i]);
}
printf("%d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: