您的位置:首页 > 其它

hdu 5437 Alisha’s Party 优先队列 2015 ACM/ICPC Asia Regional Changchun Online

2015-09-14 12:12 453 查看


Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 4409 Accepted Submission(s): 576



Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v,
and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people
enter her castle. If there are less than p people
in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please
tell Alisha who the n−th person
to enter her castle is.



Input

The first line of the input gives the number of test cases, T ,
where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated
by blanks. k is
the number of her friends invited where 1≤k≤150,000.
The door would open m times before all Alisha’s friends arrive where 0≤m≤k.
Alisha will have q queries
where 1≤q≤100.

The i−th of
the following k lines
gives a string Bi,
which consists of no more than 200 English
characters, and an integer vi, 1≤vi≤108,
separated by a blank. Bi is
the name of the i−th person
coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines
contains two integers t(1≤t≤k) and p(0≤p≤k) separated
by a blank. The door will open right after the t−th person
arrives, and Alisha will let p friends
enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated
by a space, which means Alisha wants to know who are the n1−th,...,nq−thfriends
to enter her castle.

Note: there will be at most two test cases containing n>10000.



Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.



Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran  3
Lailah 5
Mikleo  6
1 1
4 2
1 2 3




Sample Output

Sorey Lailah Rose




#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second

using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn=150000+10    ;
//const int maxm=    ;
//by yskysker123
int n,name[maxn][210];
int m,q;

struct Node
{
    int time;
    int val;

} a[maxn];

struct cmp{
    bool operator ()(Node x,Node y){

     if(x.val!=y.val)  return x.val<y.val;
    return x.time>y.time;   //int a,int b   (默认右边大)大的优先返回<  //1 ,小的优先返回大于>  //0
    }
};
int op[maxn];

struct Query
{
    int time;
    bool operator<(const Query x)const
    {
        return time<x.time;
    }
}query[maxn];
int ans[maxn];
int cnt;
 priority_queue<Node,vector<Node> ,cmp > Q;

 inline void into(int last,int now,int time)
 {
     for(int i=last;i<=now;i++)
     {
         Q.push(a[i] );
     }
     int num=op[time];
     for(int i=1;i<=num;i++)
     {
         if(Q.empty())   return;
         int time=Q.top().time;Q.pop();
         ans[++cnt]=time;
     }
 }
 void intoall(int last,int now)
 {
     for(int i=last;i<=now;i++)
     {
         Q.push(a[i] );
     }
     while(!Q.empty())
     {
         int time=Q.top().time;Q.pop();
         ans[++cnt]=time;
     }
 }
int main()
{
    int T,x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&q);
        memset(op,0,sizeof op);
        for(int i=1;i<=n;i++)
        {
            query[i].time=0;
        }
        for(int i=1;i<=n;i++)
        {
            scanf(" %s %d",name[i],&a[i].val);
            a[i].time=i;
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            if(!op[x])
            op[x]=y;
            else
            op[x]+=y;
        }
        for(int i=1;i<=q;i++)
        {
            scanf("%d",&query[i].time);

        }

        while(!Q.empty())  Q.pop();
        int last=1,now;
         cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(!op[i])  continue;
            now=i;
            into( last,now, i );

            last=now+1;

        }
        intoall(last, n );

        for(int i=1;i<=q;i++)
        {
            int time=query[i].time ;
            int p= ans[time];
            if(i>=2)  putchar(' ');
            printf("%s",name[p]);

        }
        putchar('\n');

    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: