您的位置:首页 > 其它

hdu5437 Alisha’s Party

2015-09-13 21:28 281 查看
Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v,
and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people
enter her castle. If there are less than p people
in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please
tell Alisha who the n−th person
to enter her castle is.



Input

The first line of the input gives the number of test cases, T ,
where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated
by blanks. k is
the number of her friends invited where 1≤k≤150,000.
The door would open m times before all Alisha’s friends arrive where 0≤m≤k.
Alisha will have q queries
where 1≤q≤100.

The i−th of
the following k lines
gives a string Bi,
which consists of no more than 200 English
characters, and an integer vi, 1≤vi≤108,
separated by a blank. Bi is
the name of the i−th person
coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines
contains two integers t(1≤t≤k) and p(0≤p≤k) separated
by a blank. The door will open right after the t−th person
arrives, and Alisha will let p friends
enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated
by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends
to enter her castle.

Note: there will be at most two test cases containing n>10000.



Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.



Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran  3
Lailah 5
Mikleo  6
1 1
4 2
1 2 3




Sample Output

Sorey Lailah Rose

这题可以用set或者优先队列模拟一下,每次在指定的时间读入指定的人数,这些人按照价值从大到小排序,然后当门打开的时候记录它的信息,便于待会输出结果,这里有一点要注意,就是最后m个指令读完后还有人在外面,那么把要这些人都按照规则放入门内。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 999999999
#define maxn 150060
char s[maxn][205],str[maxn][205];
int v[maxn];
struct node{
    int idx,v;
}a,temp,temp1;

bool operator<(node a,node b){
    if(a.v==b.v)return a.idx<b.idx;
    else return a.v>b.v;
}
multiset<node>myset;
multiset<node>::iterator  it;

struct node1{
    int t,num;
}b[maxn];

bool cmp(node1 a,node1 b){
    return a.t<b.t;
}

int main()
{
    int n,m,i,j,T,t,num,tot,now,c,q,ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(i=1;i<=n;i++){
            scanf("%s%d",s[i],&v[i]);
        }
        for(i=1;i<=m;i++){
            scanf("%d%d",&b[i].t,&b[i].num);
        }
        sort(b+1,b+1+m,cmp);

        tot=0;now=0;
        myset.clear();
        for(i=1;i<=m;i++){
            while(now<b[i].t){
                now++;
                a.idx=now;a.v=v[now];
                myset.insert(a);
            }
            ans=0;
            while(ans<b[i].num){
                if(myset.empty())break;
                ans++;
                it=myset.begin();
                temp=*it;
                tot++;
                strcpy(str[tot],s[temp.idx]);
                myset.erase(it);
            }

        }
        while(now<n){
            now++;
            a.idx=now;a.v=v[now];
            myset.insert(a);
        }
        while(tot<n){
            it=myset.begin();
            temp=*it;
            tot++;
            strcpy(str[tot],s[temp.idx]);
            myset.erase(it);
        }

        for(i=1;i<=q;i++){
            scanf("%d",&c);
            if(i==q){
                printf("%s\n",str[c]);
            }
            else printf("%s ",str[c]);
        }
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: