您的位置:首页 > 其它

POJ - 1962 Corporative Network(带权并查集)

2015-09-13 01:45 288 查看
Corporative Network

Time Limit: 3000MSMemory Limit: 30000KB64bit IO Format: %I64d & %I64u
Submit Status

Description

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation
started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster
B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B.
Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of
the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000)
will follow with one of the commands:

E I – asking the length of the path from the enterprise I to its serving center in the moment;

I I J – informing that the serving center I is linked to the enterprise J.

The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O


Sample Output

0
2
3
5


对n个节点,有两种操作:
E a:询问a节点到根节点的距离。
I a b:链接a点和b点且由a点指向b点,之间的距离为|a-b|%1000。

find查找压缩路径的时候要更新距离。
注意输出前调用一次find函数,处理出a到根节的的距离。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 20100;
const int MOD = 1000;

int fa[MAXN];
int dis[MAXN];

int n;

int abss(int x)
{
	return x > 0 ? x : -x;
}

void init()
{
	for (int i = 0; i <= n; i++)
	{
		dis[i] = 0;
		fa[i] = i;
	}
}

int find(int t)
{
	if (fa[t] == t)
		return t;
	int temp = fa[t];
	fa[t] = find(temp);
	dis[t] += dis[temp];
	return fa[t];
}

void union_set(int a, int b)
{
	fa[a] = b;
	dis[a] = abss(a - b) % MOD;
}

int main()
{
	int casen;
	scanf("%d", &casen);
	while (casen--)
	{
		scanf("%d", &n);
		init();

		char op;
		int a, b;

		while (cin >> op)
		{
			if (op == 'O') break;
			if (op == 'E')
			{
				scanf("%d", &a);
				find(a);
				printf("%d\n", dis[a]);
			}
			else
			{
				scanf("%d%d", &a, &b);
				union_set(a, b);
			}
		}
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: