您的位置:首页 > 其它

PAT 1093. Count PAT's (25)

2015-09-10 20:07 274 查看


1093. Count PAT's (25)

时间限制

120 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CAO, Peng

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT

Sample Output:
2


这道题有个坑,一开始以为最后算出结果取余就可以了,然后最后两个case过不了。后来发现是计算过程中就要取余。。不然可能会溢出。。代码如下:

#include <iostream>
#include <string>
using namespace std;
int main(void)
{
string raw;
int p=0,pa=0,pat=0;
cin>>raw;
for(int i=0;i<raw.size();i++)
{
if(raw[i]=='P')
p++;
else if(raw[i]=='A')
pa+=p;
else
pat+=pa;
pat%=1000000007;
}
cout<<pat;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: