您的位置:首页 > 其它

折半枚举(双向搜索)挑战程序设计竞赛

2015-09-07 23:13 405 查看
4 Values whose Sum is 0

Time Limit: 15000MSMemory Limit: 228000K
Total Submissions: 18170Accepted: 5343
Case Time Limit: 5000MS
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output
5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
Source

Southwestern Europe 2005

直接暴力枚举为O(n^4),二分+折半暴力枚举复杂度降为O(log n*n^2);
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 5000
using namespace std;
int a
, b
, c
, d
;
int ab[N*N];
int main()
{
#ifdef CDZSC
	freopen("i.txt", "r",stdin);
#endif
	int n;
	while (~scanf("%d", &n))
	{
		int q = 0;
		for (int i = 0; i <n; i++)
			scanf("%d%d%d%d",a + i, b + i, c + i, d + i);
		for (int i = 0; i < n; i++)
		{
			for (int j =0 ; j < n; j++)
			{
				ab[q++] = a[i] + b[j];
			}
		}
		sort(ab, ab + n*n);
		long long ans = 0;
		int cd;
		for (int i = 0; i <n; i++)
		{
			for (int j = 0; j < n; j++)
			{
				cd = c[i] + d[j];
				ans += upper_bound(ab, ab + n*n, -cd) - lower_bound(ab, ab +n*n, -cd);
			}
		}
		printf("%lld\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: