您的位置:首页 > 其它

1501 Zipper

2015-09-07 22:18 363 查看

Zipper

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7417 Accepted Submission(s): 2622

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in
its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the
following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree


Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no


第一次DFS的时候超时了,怎么也想不到剪枝的方法吗, 原因还是递归的方法不对,数据量是200,不可能按照普通的方法来递归,必须采用这种高端的方法、、、借鉴别人的写法,主要在于没有吃透题目,第三个串是按照前两个串的有序组合来的,因此元素肯定是一一对应的,所以采用这种直接的方法,不对应的话直接return,节省了很多的时间。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <vector>
#include <algorithm>
#include <stdlib.h>
using namespace std;
#define M 220
int n;
bool flag;
char s1[M];
char s2[M];
char s3[M*2];
int len1, len2, len3;
void DFS(int x, int y, int z){
if(flag)
return;
if(z >= len3){
flag = true;
return ;
}
if(s1[x] == s3[z])
DFS(x+1,y,z+1);
if(s2[y] == s3[z])
DFS(x,y+1,z+1);
return;
}
int main(){
scanf("%d",&n);
for(int i = 1; i <= n; i++){
memset(s1,0,sizeof(s1));
memset(s2,0,sizeof(s2));
memset(s3,0,sizeof(s3));
scanf("%s%s%s",s1,s2,s3);
len1 = strlen(s1);
len2 = strlen(s2);
len3 = strlen(s3);
flag = false;
if(s1[len1-1] == s3[len3-1] || s2[len2-1] == s3[len3-1]){
DFS(0,0,0);
}
if(flag)
printf("Data set %d: yes\n",i);
else
printf("Data set %d: no\n",i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: