您的位置:首页 > 其它

hdu 2602 Bone Collector (0-1背包)

2015-09-07 21:14 351 查看
Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

#include<stdio.h>
#include<stdlib.h>
int c[1005][1005];
int main ()
{
int t;
int i,k,j;
int v[1005];
int w[1005],n,m;
scanf ("%d",&t);
for (k=0;k<t;k++)
{
memset(c,0,sizeof(c));
scanf ("%d%d",&m,&n);
for (i=1;i<=m;i++)
{
scanf("%d",&v[i]);
}
for (i=1;i<=m;i++)
{
scanf("%d",&w[i]);
}
for (i=1;i<=m;i++)
for (j=0;j<=n;j++)
{
if (j-w[i]>=0)
{
if ((c[i-1][j-w[i]]+v[i])>c[i-1][j])
c[i][j]=c[i-1][j-w[i]]+v[i];
else
c[i][j]=c[i-1][j];
}
else
c[i][j]=c[i-1][j];
}
printf ("%d\n",c[m]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: