您的位置:首页 > 其它

1061. Dating (20)

2015-09-06 13:56 302 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1061

题目:

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since
the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours
from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings,
you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT"
for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:
THU 14:04


分析:

记得跳出条件。

AC代码:

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
string DAY[7] = { "MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN" };
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 string str1, str2, str3, str4;
 cin >> str1 >> str2 >> str3 >> str4;
 int day, hour, min  = -1;
 bool hasday = false;
 for (int i = 0, j = 0; i < str1.size() && j < str2.size(); i++, j++){
  if (str1[i] == str2[j] && (str1[i] >= 'A' && str1[i] <= 'G' && !hasday)){
    day = str1[i] - 'A';
    hasday = true;
  }
  else if (str1[i] == str2[j] && (str1[i] >= '0' && str1[i] <= '9' || str1[i] >= 'A' && str1[i] <= 'N')){
   if (hasday){
    if (str1[i] <= '9' && str1[i] >= '0'){
     hour = str1[i] - '0';
     break;
    }
    else if (str1[i] >= 'A' && str1[i] <= 'N'){
     hour = str1[i] - 'A' + 10;
     break;
    }
   }
  }
 }//for
 for (int i = 0, j = 0; i < str3.size() && j < str4.size(); i++, j++){
  if (str3[i] == str4[j] && (str3[i] >= 'a' && str3[i] <='z' || str3[i] >= 'A' && str3[i] <= 'Z')){
   min = i;
   break;
  }
 }
 printf("%s %02d:%02d\n", DAY[day].c_str(), hour, min);
 return 0;
}


截图:



因为没有考虑到第二个相同的字母找到后break,所以可能找到第三个第四个相同的字母上去,所以有错误



——Apie陈小旭
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: