您的位置:首页 > 其它

HDU 2004 成绩转换(水~)

2015-09-06 08:34 169 查看
Description

输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:

90~100为A;

80~89为B;

70~79为C;

60~69为D;

0~59为E;

Input

输入数据有多组,每组占一行,由一个整数组成

Output

对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”

Sample Input

56

67

100

123

Sample Output

E

D

A

Score is error!

Solution

水题

Code

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int x;
while(scanf("%d",&x)!=EOF)
{
if(x<0||x>100)
printf("Score is error!\n");
else if(x>=0&&x<60)
printf("E\n");
else if(x<70)
printf("D\n");
else if(x<80)
printf("C\n");
else if(x<90)
printf("B\n");
else
printf("A\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: