您的位置:首页 > 其它

1025. PAT Ranking (25)

2015-09-05 22:28 253 查看
原题地址:http://www.patest.cn/contests/pat-a-practise/1025

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2

5

1234567890001 95

1234567890005 100

1234567890003 95

1234567890002 77

1234567890004 85

4

1234567890013 65

1234567890011 25

1234567890014 100

1234567890012 85

Sample Output:

9

1234567890005 1 1 1

1234567890014 1 2 1

1234567890001 3 1 2

1234567890003 3 1 2

1234567890004 5 1 4

1234567890012 5 2 2

1234567890002 7 1 5

1234567890013 8 2 3

1234567890011 9 2 4

解题思路:简单排序题。不过写这道题的时候cmp可能有点小错误,算排名的时候稍微复杂了,不过也能ac。

代码如下:

#include <stdio.h>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

#define MAXN 102
#define MAXK 302
int N;

typedef struct testees{
char id[15];
int score;
int Local;
}test;

test t[MAXN*MAXK];
int m[MAXN*MAXK];
int curF[MAXN];
int curL[MAXN];

int cmp(const void*_a, const void*_b){
test a = *(test*)_a;
test b = *(test*)_b;
int t = b.score-a.score;
if(t > 0) return 1;
else if(t < 0) return -1;
else return strcmp(a.id,b.id);
}

int main(){
freopen("1025.txt","r",stdin);
scanf("%d",&N);
int count = 0;
int num = 0;;
for(int i = 0; i < N; i++){
int k;
scanf("%d",&k);
num += k;
for(int j = 0; j < k; j++){
test tmp;
scanf("%s %d", &tmp.id, &tmp.score);
tmp.Local = i;
//          t[i].push_back(tmp);
t[count++] = tmp;
}
}
qsort(t,count,sizeof(t[0]),cmp);
memset(m,-1,sizeof(m));
memset(curF,0,sizeof(curF));
memset(curL,0,sizeof(curL));
int cuF = 0;
int cuL = 0;
int maxT = 101;
printf("%d\n",num);
for(int i = 0; i < count; i++){
int local = t[i].Local;
if(m[local] < 0){
m[local] = t[i].score;
curF[local]++;
curL[local]++;
}else if(m[local] > t[i].score){
m[local] = t[i].score;
curL[local]++;
curF[local] = curL[local];
}else{
curL[local]++;
}

cuL++;
if(maxT > t[i].score){
cuF = cuL;
maxT = t[i].score;
}
printf("%s %d %d %d\n", t[i].id,cuF,local+1,curF[local]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: