您的位置:首页 > 其它

Mayor's posters(线段树+离散化POJ2528)

2015-09-04 16:44 387 查看
Mayor’s posters

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 51175 Accepted: 14820

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.

Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1

5

1 4

2 6

8 10

3 4

7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18

线段树的基础题目,难点就是数据比较大,但是数据数目比较少,所以可以离散化,离散化化以后,倒着进行建树,因为最后贴的肯定不会被覆盖,所以对于每一个区间,判断是否完全覆盖,如果没有完全覆盖,则说明可以看见

#include <map>
#include <set>
#include <queue>
#include <cstring>
#include <string>
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
struct node
{
int L;
int R;
} val[11000];
int a[22000];
bool Tree[11000*8];
bool flag;
int vis[10000010];
void update(int L,int R,int l,int r,int site)
{
if(Tree[site])
{
return ;
}
if(L==l&&R==r)
{
if(!Tree[site])
{
Tree[site]=true;
flag=true;
}
return ;
}
int mid=(L+R)>>1;
if(r<=mid)
{
update(L,mid,l,r,site<<1);
}
else if(l>mid)
{
update(mid+1,R,l,r,site<<1|1);
}
else
{
update(L,mid,l,mid,site<<1);
update(mid+1,R,mid+1,r,site<<1|1);
}
if(Tree[site<<1|1]&&Tree[site<<1])
{
Tree[site]=true;
}
}
int main()
{
int T;
int n;
int sum;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int top=0;
for(int i=0; i<n; i++)
{
scanf("%d %d",&val[i].L,&val[i].R);
a[top++]=val[i].L;
a[top++]=val[i].R;
}
sort(a,a+top);//排序去重
int ans=0,cnt=0;
vis[a[0]]=++cnt;;
ans=a[0];
int i=0;
while(i<top&&a[i]==ans)
{
i++;
}
for(;i<top;)
{
vis[a[i]]=++cnt;
ans=a[i];
while(i<top&&a[i]==ans)
{
i++;
}
}
memset(Tree,false,sizeof(Tree));
sum=0;
for(int i=n-1; i>=0; i--)
{
flag=false;
update(1,cnt,vis[val[i].L],vis[val[i].R],1);
if(flag)
{
sum++;
}
}
printf("%d\n",sum);
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: