您的位置:首页 > 其它

Regionals 2014 >> Latin America 6822 - Black a

2015-09-03 09:11 253 查看
6822

Black and white stones

Shagga and Dolf like to play a game with stones, each of which is either black or white. At the beginning

of the game, Dolf arranges all the stones in a single line from left to right. Then, Shagga’s goal is to

reorder the stones so that all the black stones are to the left of all the white stones. To do this, he

can choose any pair of stones of different color and swap their positions, paying A coins to Dolf in the

process. However, if the two stones whose positions he is swapping are adjacent, Dolf must give him a

refund of B coins, meaning that the operation will effectively cost Shagga only A − B coins.

Shagga is not very bright, so he hasn’t realized yet that he will only loose coins while playing this

game. However, he is aware of his limitations, so he knows that if he played optimally he would loose

fewer coins than he is loosing right now, with his strategy of randomly choosing the stones he swaps in

each movement. Therefore, he wants to know the minimum number of coins he will have to pay Dolf

in order to get to the desired arrangement of stones, and is threatening to feed you to the goats if you

don’t help him.

Input

The input contains several test cases; each test case is formatted as follows. The first line contains two

integers A and B (0 ≤ B < A ≤ 106), representing respectively the cost of swapping two stones and

the value of the refund when swapping adjacent stones. The second line contains a non-empty string

S of at most 5000 characters. The i-th character of S indicates the color of the i-th stone, from left to

right, in the initial arrangement of the stones. The character is either the uppercase letter ‘B’ or the

uppercase letter ‘W’, indicating respectively a black or a white stone.

Output

For each test case in the input, output a line with an integer representing the minimum number of coins

Shagga will have to pay Dolf in order to arrange the stones such that all the black ones are to the left

of all the white ones.

Sample Input

2 1

BWWB

5 3

WBWWBWBWBWBBBWWBBB

1000000 0

W

Sample Output

2

27

0

题意:把所有的黑色(B)移到左边、白色(W)移到右边的最小花费。每交换,花费为a,若交换的为相邻位置则只需花费a-b

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <vector>
using namespace std;

typedef long long ll;
#define MAX 20005
#define PI acos(-1.0)
ll min(ll a,ll b){
if(a > b) return b;
else return a;
}
ll f[50005]; //在此位置前(包含自己)有多少个B
ll cnt[50005]; //在第i个B前有多少个W
int main(){
ll a,b;
while(~scanf("%lld%lld", &a, &b)){
string s;
cin >> s;
ll len = (ll)s.size();
ll tot = 0;
b = a-b;
memset(f,0,sizeof(f));
memset(cnt,0,sizeof(cnt));
int n = 1;
for(ll i = 0;i < len;i++){
if(s[i] == 'B'){
f[i] = 1;
cnt
= tot;
n ++;
}
else{
cnt
= ++tot;
}
}
n --;
for(ll i = 1;i < len;i++) f[i] += f[i-1];
for(ll i = 1;i <= n;i++) cnt[i] += cnt[i-1];
ll mmin = b*cnt
;
for(ll i = 0;i < len;i++){
if(s[i] == 'W'){
ll tmp = i+1-f[i];  //在此i前有多少个W(包括自己)
if(n-tmp-f[i] < 0) break;  //注意跳出
//cout << mmin << " " << tmp*a << " " << b << " " << cnt[n-tmp]-cnt[f[i]] << " " << n-tmp-f[i] << endl;
mmin = min(mmin,tmp*a+b*(cnt[n-tmp]-cnt[f[i]]-tmp*(n-tmp-f[i])));
}
}

printf("%lld\n", mmin);
}
return 0;
}
/*4 3
BWWWWWBWBWBWWBWBWBWWWB
6 2
BWWBWBWWWBWBBBBW
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: