您的位置:首页 > 其它

UVA_11636_HelloWorld!

2015-09-02 21:21 295 查看


11636 - Hello World!

Time limit: 1.000 seconds

When you rst made the computer to print the sentence \Hello World!", you felt so happy, not

knowing how complex and interesting the world of programming and algorithm will turn out to be.

Then you did not know anything about loops, so to print 7 lines of \Hello World!", you just had to

copy and paste some lines. If you were intelligent enough, you could make a code that prints \Hello

World!" 7 times, using just 3 paste commands. Note that we are not interested about the number

of copy commands required. A simple program that prints \Hello World!" is shown in Figure 1. By

copying the single print statement and pasting it we get a program that prints two \Hello World!"

lines. Then copying these two print statements and pasting them, we get a program that prints four

\Hello World!" lines. Then copying three of these four statements and pasting them we can get a

program that prints seven \Hello World!" lines (Figure 4). So three pastes commands are needed in

total and Of course you are not allowed to delete any line after pasting. Given the number of \Hello

World!" lines you need to print, you will have to nd out the minimum number of pastes required to

make that program from the origin program shown in Figure 1.

Input

The input le can contain up to 2000 lines of inputs. Each line contains an integer N (0 < N < 10001)

that denotes the number of \Hello World!" lines are required to be printed.

Input is terminated by a line containing a negative integer.

Output

For each line of input except the last one, produce one line of output of the form `Case X: Y ' where

X is the serial of output and Y denotes the minimum number of paste commands required to make a

program that prints N lines of \Hello World!".

Sample Input

2

10

-1

Sample Output

Case 1: 1

Case 2: 4

今天在UVA注册了账号,用这个helloworld记录下吧

这个题目说的可以复制一部分,因此就找大于它的最近的二进制值就可以了

#include <iostream>
#include <stdio.h>
using namespace std;

int er[20]={1};

int main()
{
int ca=1;
for(int i=1;er[i-1]<10005;i++)
er[i]=er[i-1]*2;
int n;
while(scanf("%d",&n)!=EOF)
{
if(n<0)
break;
int p=0;
while(n>er[p])
p++;
printf("Case %d: %d\n",ca++,p);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: