您的位置:首页 > 其它

1013. Battle Over Cities (25)

2015-09-02 15:03 671 查看
题目地址:http://www.patest.cn/contests/pat-a-practise/1013

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3

1 2

1 3

1 2 3

Sample Output

1

0

0

并查集求解如下:

#include <cstdio>
#include <iostream>
#include <vector>
#include <set>
using namespace std;

#define N  1005
#define INF 999999999

int n , m , kk ;

struct edge{
int u ;
int v ;
bool flag;
};

int fa
;

int find(int x)
{
if(x == fa[x] )
return  x ;
return fa[x] = find(fa[x]);
}

void merge(int x, int y)
{
fa[find(y)] = fa[find(x)];
}

vector<edge> ve;

int mfun(int tmp)
{
int i ;
set<int> ss;
for(i = 1 ; i <= n ; i++)
{
ss.insert(find(i));
}
int len = ss.size();
return len - 1 - 1;
}

int main()
{
//freopen("in.txt", "r", stdin);
scanf("%d%d%d",&n,&m,&kk);
int i ,j ;
edge et;
for(i = 0 ; i < m ; i++)
{
scanf("%d%d",&et.u , &et.v) ;
et.flag = true;
ve.push_back(et);
}

int tmp ;
while( kk-- )
{
scanf("%d" , &tmp);

for(i = 1 ; i <= n ; i ++)
{
fa[i] = i ;
}
for(i = 0 ; i < m ; i ++)
{
et = ve[i];
if(et.u != tmp && et.v != tmp)
{
if(find(et.u) != find(et.v) )
{
merge(et.u , et.v) ;
}
}
}
printf("%d\n",mfun(tmp));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: