您的位置:首页 > 其它

HDU 1113

2015-09-01 19:21 239 查看


Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2897    Accepted Submission(s): 1398


Problem Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a
program that can unscramble words. 

 

Input

The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 

2. a line containing XXXXXX, which signals the end of the dictionary; 

3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 

4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in
sorted order, but each word in the dictionary is unique. 

 

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary
words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

 

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

 

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
先用排序统一一种方式 然后等输入后扫一遍就OK
#include <iostream>  
#include <string>  
#include <map>  
#include <algorithm>  
using namespace std;
map<string, string> str;
string a,b;
int main()
{
while(cin>>a&&a!="XXXXXX")
{
b=a;
sort(b.begin(),b.end());
str[a]=b;
}
while(cin>>a&&a!="XXXXXX")
{
b=a;
bool mark=0;
sort(b.begin(),b.end());
map<string, string>::iterator it;
for(it=str.begin();it!=str.end();it++)
{
if(it->second==b)
{
cout<<it->first<<endl;
mark=1;
}
}
if(!mark)

                cout << "NOT A VALID WORD"<<endl;  
}
        cout << "******"<<endl; 
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: