您的位置:首页 > 运维架构

hdu 4368 树状数组 离线维护

2015-08-29 12:42 225 查看
http://acm.hdu.edu.cn/showproblem.php?pid=4638

Problem Description

There are n men ,every man has an ID(1..n).their ID is unique. Whose ID is i and i-1 are friends, Whose ID is i and i+1 are friends. These n men stand in line. Now we select an interval of men to make some group. K men in a group can create K*K value. The value
of an interval is sum of these value of groups. The people of same group's id must be continuous. Now we chose an interval of men and want to know there should be how many groups so the value of interval is max.

 

Input

First line is T indicate the case number.

For each case first line is n, m(1<=n ,m<=100000) indicate there are n men and m query.

Then a line have n number indicate the ID of men from left to right.

Next m line each line has two number L,R(1<=L<=R<=n),mean we want to know the answer of [L,R].

 

Output

For every query output a number indicate there should be how many group so that the sum of value is max.

 

Sample Input

1
5 2
3 1 2 5 4
1 5
2 4

 

Sample Output

1
2

/**
hdu 4368 树状数组
题目大意:给定1~n的一个排列,每次查询一个区间(l,r),将所求区间内的数进行分组,每一组内的数的值必须是连着的,该组的价值为元素个数的平方和
问在区间价值最大的情况下,要分成几组
解题思路:用树状数组离线维护,把询问按照右区间递增排序,然后从1~n维护,维护到i时注意找寻前i个是不是有a[i]-1,和a[i]+1,有的话直接去掉,因为
这两个数必定要和a[i]分到一组,留一个就好了
*/
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;
const int maxn=100100;
int n,m,a[maxn],p[maxn],ans[maxn];
struct note
{
int l,r,id;
bool operator < (const note &other)const
{
return r<other.r;
}
}que[maxn];

int c[maxn];

int lowbit(int x)
{
return x&(-x);
}
int sum(int x)
{
int ret=0;
while(x>0)
{
ret+=c[x];x-=lowbit(x);
}
return ret;
}

void add(int x,int d)
{
while(x<=n)
{
c[x]+=d;
x+=lowbit(x);
}
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
p[a[i]]=i;
}
for(int i=0;i<m;i++)
{
scanf("%d%d",&que[i].l,&que[i].r);
que[i].id=i;
}
sort(que,que+m);
memset(c,0,sizeof(c));
int j=0;
for(int i=1;i<=n;i++)
{
add(i,1);
if(a[i]>1&&p[a[i]-1]<i)add(p[a[i]-1],-1);
if(a[i]<n&&p[a[i]+1]<i)add(p[a[i]+1],-1);
while(j<m&&que[j].r==i)
{
ans[que[j].id]=sum(que[j].r)-sum(que[j].l-1);
j++;
}
}
for(int i=0;i<m;i++)
{
printf("%d\n",ans[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: