您的位置:首页 > 其它

1000 -- A+B Problem

2015-08-29 02:59 477 查看
A+B Problem
Time Limit:1000MS Memory Limit:10000K

Total Submit:1388 Accepted:685
Description
Calculate a+b

Input
Two integer a,b (0<=a,b<=10)

Output
Output a+b

Sample Input
1 2

Sample Output
3

Hint
Q: Where are the input and the output?

A: Your program shall always read input from stdin (Standard Input) and write output to stdout (Standard Output). For example, you can use 'scanf' in C or 'cin' in C++ to read from stdin, and use 'printf' in C or 'cout' in C++
to write to stdout.

You shall not output any extra data to standard output other than that required by the problem, otherwise you will get a "Wrong Answer".

User programs are not allowed to open and read from/write to files. You will get a "Runtime Error" or a "Wrong Answer" if you try to do so.

Here is a sample solution for problem 1000 using C++/G++:

#include < iostream >

using namespace std;

int  main()

{

int a,b;

cin >> a >> b;

cout << a+b << endl;

return 0;

}


It's important that the return type of main() must be int when you use G++/GCC,or you may get compile error.

Here is a sample solution for problem 1000 using C/GCC:

#include < stdio.h >

int main()

{

int a,b;

scanf("%d %d",&a, &b);

printf("%d\n",a+b);

return 0;

}


Here is a sample solution for problem 1000 using PASCAL:

program p1000(Input,Output);

var

a,b:Integer;

begin

Readln(a,b);

Writeln(a+b);

end.


Here is a sample solution for problem 1000 using JAVA:

Now java compiler is jdk 1.7(1.5 higher), next is program for 1000

import java.io.*;

import java.util.*;

public class Main

{

public static void main(String args[]) throws Exception

{

Scanner cin=new Scanner(System.in);

int a=cin.nextInt(),b=cin.nextInt();

System.out.println(a+b);

}

}


C# Code:

using System;

class Acm1000

{

static void Main()

{

string[] ss = Console.ReadLine().Split();

Console.WriteLine(long.Parse(ss[0]) + long.Parse(ss[1]));

}

}


Python(2.7) Code:

import sys

a,b=map(int, sys.stdin.read().split())

print a+b

Source
POJ

using System;
class Acm1000
{
static void Main()
{
string[] ss = Console.ReadLine().Split();
Console.WriteLine(long.Parse(ss[0]) + long.Parse(ss[1]));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: