您的位置:首页 > 其它

zoj1586(prim)

2015-08-28 10:03 127 查看
QS Network

Time Limit: 2 Seconds Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please
be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the
group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.
A sample is shown below:



A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.
Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand
of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input
The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.
Constrains:
all the integers in the input are non-negative and not more than 1000.

Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input
1

3

10 20 30

0 100 200

100 0 300

200 300 0

Sample Output
370

/*
题意:
求最小生成树,裸
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <set>
#include <cmath>
#include <vector>
#include<cstdlib>
#define INF 1000000007
#define eps 1e-6
#pragma comment (linker,"/STACK:102400000,102400000")
using namespace std;
#define maxn 1500
int vis[maxn];
int map_[maxn][maxn];
int value[maxn];
int dis[maxn];
int n;
int m;
void prim()
{
    int min_cost=0;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        dis[i]=map_[1][i]+value[1]+value[i];
        dis[1]=0;

    vis[1]=1;
    for(int i=1;i<=n;i++)
    {
        int minn=INF;
        int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && dis[j]<minn)
                minn=dis[k=j];
        }
        if(k!=-1)
        {
            vis[k]=1;
            min_cost+=minn;
            for(int j=1;j<=n;j++)
                if(dis[j]>map_[k][j]+value[k]+value[j])
                dis[j]=map_[k][j]+value[j]+value[k];
        }
    }
    cout<<min_cost<<endl;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&value[i]);

         for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        scanf("%d",&map_[i][j]);
        prim();
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: