您的位置:首页 > 运维架构

POJ 3258 River Hopscotch(二分法)

2015-08-27 18:45 134 查看
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2
2
14
11
21
17

Sample Output
4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目大意:
一维坐标0~L之间是一条河,中间有n个十块,可以从0开始跳跃到石头上过河到达L,给定n个石块的坐标,要求拿走任意m块石头,使最小跳跃距离最大
解题思路:
二分枚举答案,根据当前枚举答案判断可移动的石块数,决定枚举方向,详见代码

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-8
#define MAX_V 100010
#define MAX_P 110
#define MAX_E 10010
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

int L,n,m;
int s[50050];

int Remove(int mid)
{
int cnt=0;
for(int i=1,j=0;i<=n+1;i++)
{
if(s[i]-s[j]<=mid)
cnt++;
else
j=i;
}
return cnt;
}

int main()
{
//STD_REOPEN();
while(~scanf("%d %d %d",&L,&n,&m))
{
for(int i=1;i<=n;i++)
scanf("%d",&s[i]);
s[0]=0;
s[n+1]=L;
sort(s,s+n+2);
int l=0,r=2*L;
while(l<=r)
{
int mid=(l+r)>>1;
int tmp=Remove(mid);
if(tmp>m)
r=mid-1;
else
l=mid+1;
}
printf("%d\n",l);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: