您的位置:首页 > 其它

Moving Tables(贪心或Dp POJ1083)

2015-08-27 17:02 281 查看
Moving Tables

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28304Accepted: 9446
Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to
move.

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd

line, the remaining test cases are listed in the same manner as above.
Output

The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output

10
20
30

Source

Taejon 2001

开始做的时候用的贪心后来感觉好麻烦,就又写的Dp;

贪心

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>

using namespace std;

typedef struct node
{
int L;
int R;
bool operator <(const node &a)const
{
if(L<a.L||(L==a.L&&R<a.R))
{
return true;
}
return false;
}
} Edge;

Edge a[300];

bool vis[300];

int main()
{
int T,n,x,y;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=0; i<n; i++)
{
scanf("%d %d",&x,&y);
if(x>y)
{
swap(x,y);
}
if(x&1)
{
a[i].L=(x+1)/2;
}
else
{
a[i].L=x/2;
}
if(y&1)
{
a[i].R=(y+1)/2;
}
else
{
a[i].R=y/2;
}

}
sort(a,a+n);
memset(vis,false,sizeof(vis));
int sum=0;
while(1)
{
int ans=-1;
for(int i=0; i<n; i++)
{
if(!vis[i])
{
if(a[i].L>ans)
{
ans=a[i].R;
vis[i]=true;
}
}
}
if(ans==-1)
{
break;
}
else
{
sum++;
}
}
printf("%d\n",sum*10);
}
return 0;
}


Dp

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
int Dp[201];
int main()
{
int T,n,x,y;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
memset(Dp,0,sizeof(Dp));
for(int i=0; i<n; i++)
{
scanf("%d %d",&x,&y);
if(x>y)
{
swap(x,y);
}
x=(x+1)/2;
y=(y+1)/2;
Dp[x]+=1;
Dp[y+1]-=1;
}
int sum=0;
for(int i=1;i<201;i++)
{
Dp[i]+=Dp[i-1];
sum=max(sum,Dp[i]);
}
printf("%d\n",sum*10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: