您的位置:首页 > 理论基础 > 计算机网络

Kids and Prizes 来源: <http://acm.hust.edu.cn/vjudge/contest/view.action?cid=85996#problem/B>

2015-08-26 22:20 549 查看
B - Kids and Prizes
Time Limit:250MS Memory Limit:262144KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are N prizes for the winners,
each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:

All the boxes with prizes will be stored in a separate room.
The winners will enter the room, one at a time.
Each winner selects one of the boxes.
The selected box is opened by a representative of the organizing committee.
If the box contains a prize, the winner takes it.
If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
Whether there is a prize or not, the box is re-sealed and returned to the room.

The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number
of prizes given (the certificates are not counted as prizes, of course).

Input

The first and only line of the input file contains the values of N and M (

).

Output

The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10 -9.

Sample Input

sample input

sample output

5 7

3.951424

sample input

sample output

4 3

2.3125


自己的思路,是枚举获奖个数相乘,完全不行;

无奈看了题解:题解是算每个人获一个奖品的概率dp[i],这样sum(i*dp[i]) 就是结果了

对于dp[i]=(1-dp[i-1])*(dp[i-1]) + dp[i-1]*(dp[i-1]-1.0/n);

若(i-1)获得,则i获得的概率为 (dp[i-1]-1.0/n);

若(i-1)未得,则i获得的概率 dp[i-1];

递推
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
const int maxn=100000+10;
double dp[maxn];
int n,m;
int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        dp[1]=1.0;
        for(int i=2;i<=m;i++)
        {
            dp[i]=(1-dp[i-1])*dp[i-1]+dp[i-1]*(dp[i-1]-1.0/n);
        }
        double ret=0.0;
        for(int i=1;i<=m;i++)
        {
            ret+=dp[i];
        }
        printf("%.9f\n",ret);
    }

    return 0;
}


dfs递归

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
const int maxn=100000+10;
double dp[maxn];
int n;
double dfs(int x)
{
    if(dp[x]!=-1) return dp[x];
    if(x==1) return dp[x]=1.0;
    else return dp[x]=dfs(x-1)*(dfs(x-1)-1.0/n)+(1-dfs(x-1))*dfs(x-1);
}
int main()
{
    int m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(int i=0;i<=m;i++)
        {
            dp[i]=-1.0;
        }
        dfs(m);
        double ret=0.0;
        for(int i=1;i<=m;i++)
        {
            ret+=dp[i];
        }
        printf("%.9f\n",ret);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: