您的位置:首页 > 其它

Tiling POJ 2506

2015-08-25 19:25 375 查看
Description
In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?

Here is a sample tiling of a 2x17 rectangle.



Input
Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output
For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input
2
8
12
100
200

Sample Output
3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source
The UofA Local 2000.10.14

一看题,我靠,这么长,递推+高精度运算,可惜当时不会,看了题解才明白了。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>

using namespace std;

int ans[260][300];
int main()
{
int n,i,j;
while(scanf("%d",&n)!=EOF)
{
memset(ans,0,sizeof(ans));
ans[0][0]=1;
ans[1][0]=1;
ans[2][0]=3;
if(n<=2)
{
printf("%d\n",ans
[0]);
}
else
{

int s=0;
int temp=0;
for(i=3; i<=n; i++)
{
for(j=0; j<300; j++)//把数据存入数组,高精度运算
{
s=ans[i-1][j]+ans[i-2][j]*2+temp;
ans[i][j]=s%10;
temp=s/10;
}
}
int flog=0;
for(i=300; i>=0; i--)//从最后面输出
{
if(flog!=0||ans
[i]!=0)//flog是防止结果中间出现0的情况,至于结尾,应该不会出现0。
{
flog=1;
printf("%d",ans
[i]);
}
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: