您的位置:首页 > 其它

HDOJ--1385--Minimum Transport Cost(最短路记录路径)

2015-08-24 21:39 351 查看


Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8895 Accepted Submission(s): 2342



Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.



Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN

b1 b2 ... bN

c d

e f

...

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:



Output

From c to d :

Path: c-->c1-->......-->ck-->d

Total cost : ......

......

From e to f :

Path: e-->e1-->..........-->ek-->f

Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.



Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0




Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17



题意:大体上意思就是给你一个无向图,并且给你这几个城市的税收情况,当你经过一个城市(不是起点城市,也不是终点城市)的时候要加生这个城市收税情况。最后要让你输出路径。
思路;设置一个前驱数组,来记录每一步走的路径。最后输出这个路径即可。
ac代码:
#include<stdio.h>
#define INF 0x3f3f3f3f 
int n,dis[550][550],pre[550][550],c[550];
void getmap(){
	int cost;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++){
			scanf("%d",&cost);
			if(cost==-1)
				dis[i][j]=INF;
			else
				dis[i][j]=cost;
			pre[i][j]=j; //创建一个前驱数组来记录每一步,对前驱数组进行初始化。
		}
	for(int i=1;i<=n;i++)
		scanf("%d",&c[i]);
}
void floyd(){
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			if(dis[i][k]!=INF){//一种剪枝优化。
				for(j=1;j<=n;j++){
					if(dis[i][j]>dis[i][k]+dis[k][j]+c[k]){//对前驱数组和花费数组进行更新。
						dis[i][j]=dis[i][k]+dis[k][j]+c[k];
						pre[i][j]=pre[i][k];
					}
						
					else if(dis[i][j]==dis[i][k]+dis[k][j]+c[k]){//如果花费相同的话,按字典序记录前驱数组;
						if(pre[i][j]>pre[i][k])
							pre[i][j]=pre[i][k];
					}
				}
			}
}
int main(){
	while(scanf("%d",&n)!=EOF&&n!=0){
		getmap();
		floyd();
		int a,b;
		while(scanf("%d%d",&a,&b)!=EOF&&a!=-1&&b!=-1){
			printf("From %d to %d :\nPath: %d",a,b,a);
			int temp=a;
			while(temp!=b){//输出路径。
				temp=pre[temp][b];
				printf("-->%d",temp);
			}
			printf("\nTotal cost : %d\n\n",dis[a][b]);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: