您的位置:首页 > 其它

hdoj 3665 Seaside 【最短路&&SPFA】

2015-08-24 10:51 357 查看

Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1374 Accepted Submission(s): 989



[align=left]Problem Description[/align]
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed
that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

[align=left]Input[/align]
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines
followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that
the distance between the i-th town and the SMi town is LMi.

[align=left]Output[/align]
Each case takes one line, print the shortest length that XiaoY reach seaside.

[align=left]Sample Input[/align]

5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1


[align=left]Sample Output[/align]

2


分析:

小明想去海边,给出去海边的几个路径,求小明到海边的最短路径。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define maxn 1010
#define INF 0x3f3f3f3f
using namespace std;
int n;
int dis[maxn];
int vis[maxn];
int head[maxn*10];
int ff[maxn];
struct node{
int from;
int to;
int val;
int next;
};
node pp[maxn*10];
int pnum;

void addpp(int u,int v,int w)
{
node E={u,v,w,head[u]};
pp[pnum]=E;
head[u]=pnum++;
}

void SPFA(int s)
{
memset(dis,INF,sizeof(dis));
memset(vis,0,sizeof(vis));
queue<int>q;
dis[s]=0;
vis[s]=1;
q.push(s);
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=pp[i].next)
{
int v=pp[i].to;
if(dis[v]>dis[u]+pp[i].val)
{
dis[v]=dis[u]+pp[i].val;
if(!vis[v])
{
vis[v]=1;
q.push(v);
}
}
}
}
}

int main()
{
int a,b,c,d,i,j,k;
while(scanf("%d",&n)!=EOF)
{
int cnt=0;
pnum=0;
memset(head,-1,sizeof(head));
for(i=0;i<n;i++)
{

scanf("%d%d",&d,&k);
if(k==1)
ff[cnt++]=i;
while(d--)
{
scanf("%d%d",&b,&c);
addpp(i,b,c);
addpp(b,i,c);
}
}
int mn=INF;
SPFA(0);
for(i=0;i<cnt;i++)
{

if(mn>dis[ff[i]])
mn=dis[ff[i]];
}
printf("%d\n",mn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: