您的位置:首页 > 其它

hdu 5417 Victor and Machine(简单数学题)

2015-08-23 09:27 309 查看

Victor and Machine

[align=center][/align]

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 232 Accepted Submission(s): 128
点击打开链接

[align=left]Problem Description[/align]
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every
w
seconds. However, the machine has some flaws, every time after x
seconds of process the machine has to turn off for y
seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

Now, at the 0
second, the machine opens for the first time. Victor wants to know when the
n-th
ball will be popped out. Could you tell him?

[align=left]Input[/align]
The input contains several test cases, at most
100
cases.

Each line has four integers x,
y,
w
and n.
Their meanings are shown above。

1≤x,y,w,n≤100.

[align=left]Output[/align]
For each test case, you should output a line contains a number indicates the time when the
n-th
ball will be popped out.

[align=left]Sample Input[/align]

2 3 3 3
98 76 54 32
10 9 8 100


[align=left]Sample Output[/align]

10
2664
939


题目

[align=left]Sample Output[/align]

10
2664
939


[align=left]题目大意:一个机器每隔w (/s)弹射一颗小球,机器开启的瞬间(第0时刻)会有一颗小球弹出,但是每隔 x (/s)机器会关机,修整y (/s)然后重启。[/align]
[align=left]很明显是一个以 ( x+y) 为周期的题目,求出每个周期会有几颗小球弹射就可以了,注意边界小球的处理。需要注意的是如果 w > x 那么w将是没有用的条件,而且时间不进行累计。 [/align]

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
typedef long long ll;
int main()
{
ll x,y,w,n;
while(scanf("%I64d%I64d%I64d%I64d",&x,&y,&w,&n)!=EOF)
{
ll temp = x/w+1;

ll turn = n/temp;
ll yu = n%temp;
if(yu == 0)
{
printf("%I64d\n",(turn-1)*(x+y)+(temp-1)*w);
}
else
{
printf("%I64d\n",(turn)*(x+y)+(yu-1)*w);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: