您的位置:首页 > 其它

hdu 2.2.4 Wolf and Rabbit 解题心得

2015-08-21 19:55 337 查看
原题:

Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

Sample Input

2
1 2
2 2

Sample Output

NO
YES

分析:
这个题题意是一个圆形的山环绕着兔子洞,狼会每隔一定的洞数会进洞找兔子,因为是圆所以可以循环,
必定有规律,我是写个暴力程序,打印出20组数据找出规律的,规律就是互质就有遗漏,否则没有遗漏

代码:

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;

int gcd(int a, int b)
{
if (b == 0)
{
cout << a << endl;
return a;
}
else
{
cout << gcd(b, a%b) << endl;
return gcd(b, a%b);
}
}
int main()
{
gcd(6, 4);
int t;
cin >> t;
int a, b;
while (t--)
{
cin >> a >> b;
if (gcd(a, b) == 1)
{
puts("NO");
}
else
{
puts("YES");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: