您的位置:首页 > 其它

Poj.2398 Toy Storage【数学几何】 2015/08/21

2015-08-21 17:55 211 查看
Toy Storage

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4620Accepted: 2734
Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the
box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.

Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:



We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left
corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that
the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.
Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing
t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output
Box
2: 5
Box
1: 4
2: 1

Source

Tehran 2003 Preliminary

注:类似于2318题,是2318题的变形,只是输出不同,此题需要统计区域内点的个数为i的区域的个数,而且输入的区域不是按照从左到右的顺序输入的,需要先排序

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int n,m,a,b,c,d,ans[5010],ret[5010];

struct node{
int x,y;
}edge[5010],point[5010];

bool cmp(node a,node b){
if( a.x == b.x )
return a.y < b.y;
return a.x < b.x;
}

bool ok(int a,int b){
if( point[a].x == edge[b].y ){
if( edge[b].x > edge[b].y )
return true;
return false;
}
if( edge[b].x == edge[b].y ){
if( point[a].x < edge[b].x )
return true;
return false;
}
double k1 = ( point[a].y - c ) * 1.0 / ( point[a].x - edge[b].y ) ;
double k2 = ( d - c ) * 1.0 / ( edge[b].x - edge[b].y ) ;
if( k1 < 0 && k2 > 0 )
return true;
if( k1 > 0 && k2 < 0 )
return 0;
if( k1 > k2 )
return true;
return false;
}

int judge(int k){
for( int i = 0 ; i < n ; ++i ){
if( ok(k,i) )
return i;
}
return n;
}

int main(){
while( scanf("%d%d%d%d%d%d",&n,&m,&a,&d,&b,&c),n ){
memset(ans,0,sizeof(ans));
for( int i = 0 ; i < n ; ++i )
scanf("%d%d",&edge[i].x,&edge[i].y);
sort(edge,edge+n,cmp);
for( int i = 0 ; i < m ; ++i ){
scanf("%d%d",&point[i].x,&point[i].y);
ans[judge(i)]++;
// printf("%=====%d\n",judge(i));
}
memset(ret,0,sizeof(ret));
for( int i = 0 ; i <= n ; ++i )
ret[ans[i]]++;
//for( int i = 0 ; i <= m ; ++i )
// printf("===%d\n",ret[i]);
printf("Box\n");
for( int i = 1 ; i <= m ; ++i )
if( ret[i] )
printf("%d: %d\n",i,ret[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: