您的位置:首页 > 其它

Can you find it?

2015-08-20 20:28 246 查看
[align=left]Problem Description[/align]
[align=left] [/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

[align=left]Input[/align]
[align=left] [/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there
are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

[align=left]Output[/align]
[align=left] [/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print
"NO".

[align=left]Sample Input[/align]
[align=left] [/align]
3 3 3

1 2 3

1 2 3

1 2 3

3

1

4

10

[align=left]Sample Output[/align]
[align=left] [/align]
Case 1:

NO

YES

NO

#include<stdio.h>
#include<algorithm>
#define max 550
#define max1 302500
using namespace std;
int a[max],b[max],c[max];
int ab[max1];//这个数组开大点 ,会有max*max个 元素
int main()
{
int l,m,n,p=0,i,j;
scanf("%d%d%d",&l,&m,&n);
for(i=0;i<l;i++)
scanf("%d",&a[i]);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
for(i=0;i<n;i++)
scanf("%d",&c[i]);
for(i=0;i<l;i++)
for(j=0;j<m;j++)
ab[p++]=a[i]+b[j];//<span style="color:#ff0000;">当你不知道一个数组有多少元素时,就用这种写法
</span>				  //最终ab[]中的元素个数就是p;(p的初始值为1!)
sort(ab,ab+p);//不写cmp就默认升序
int s,x,d=0;
scanf("%d",&s);
printf("Case %d:\n",++d);
while(s--)
{
scanf("%d",&x);
int mid,flag=0; //flag的初始值必须是0。right是ab[]
for(i=0;i<n;i++)//的最大下标。
{

while(left<=right)//当没有找到合适的值时,跳出该层循环时flag=0;
{
int left=0,right=p-1;
mid=(left+right)/2;
if(ab[mid]+c[i]==x)
{
flag=1;break;//找到之后跳出while循环
}

else if(ab[mid]+c[i]<x)
left=mid+1;
else if(ab[mid]+c[i]>x)
right=mid-1;
}
if(flag==1) break;//找到之后跳出for循环
}
if(flag==1)
printf("YES\n");
else printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: