您的位置:首页 > 运维架构

hdoj 2795 Billboard 【线段树 单点更新 + 维护区间最大值】

2015-08-20 18:22 357 查看

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15719 Accepted Submission(s): 6629

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.


Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.


Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.


Sample Input
3 5 5
2
4
3
3
3




Sample Output
1
2
1
3
-1




题意:有一个高h宽w的公告栏,现在要在上边贴N个1*W的公告。要求1,要在能够完全放下的区域贴公告。2,贴公告时遵循最上最左的原则。问你每张公告分别贴在第几行,若公告无法插入输出-1。

思路:以min(h, N)为区间右边界建立线段树,初始化每个区间最大值Max为w。
之后每次贴公告就是——找一个Max值最大的区间插入 + 维护区间最大值。若Max[1] < W说明不能插入。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 200000+10
using namespace std;
int Max[MAXN<<2];
void PushUp(int o)
{
    Max[o] = max(Max[o<<1], Max[o<<1|1]);
}
void build(int o, int l, int r, int val)
{
    Max[o] = val;
    if(l == r)
        return ;
    int mid = (l+r) >> 1;
    build(o<<1, l, mid, val);
    build(o<<1|1, mid+1, r, val);
    PushUp(o);
}
int query(int o, int l, int r, int v)
{
    if(l == r)
    {
        Max[o] -= v;
        return l;
    }
    int mid = (l + r) >> 1;
    int ans;
    if(Max[o<<1] >= v)//左子树
        ans = query(o<<1, l, mid, v);
    else//右子树
        ans = query(o<<1|1, mid+1, r, v);
    PushUp(o);//维护区间最值  不能少!
    return ans;
}
int main()
{
    int h, w, N;
    while(scanf("%d%d%d", &h, &w, &N) != EOF)
    {
        h = min(N, h);//逗比了 用N来更新 结果样例都过不了
        build(1, 1, h, w);
        int W;
        while(N--)
        {
            scanf("%d", &W);
            if(Max[1] < W)
                printf("-1\n");
            else
                printf("%d\n", query(1, 1, h, W));
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: