您的位置:首页 > 其它

POJ 1035 Spell checker

2015-08-20 14:36 411 查看
字符数组开小了wa好多次。。。。pe一次 哎水题

Spell checker

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 22862Accepted: 8314
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000
words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct".
If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary
(in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source
Northeastern Europe 1998
[Submit] [Go
ACcode:

#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 10000+5
using namespace std;
struct Note{
    char word[20];
}my[maxn];
int n=0;
char t[20];
char txt[maxn][20];
int tlen[maxn];
Note *pos;
int cmp(const void *a,const void *b){
    return strcmp(((Note*)a)->word,((Note*)b)->word);
};
int bcmp(const void *a,const void *b){
    return strcmp(((char*)a),((Note*)b)->word);
};
bool fun1(char *a,char *b,int l){
    int cnt=0;
    for(int i=0;i<l;++i){
        if(a[i]==b[i])
            cnt++;
    }
    if(cnt+1==l)return true;
    return false;
};
bool fun2(char *a,char *b){
    int flag=0;
    while(*a){
        if(*a!=*b){
            b++;
            flag++;
            if(flag>1)
                return false;
        }
        else {
            a++;
            b++;
        }
    }
    return true;
};
int main(){
    int n=0;
    while(scanf("%s",txt
)!=EOF&&strcmp("#",txt
)){
        strcpy(my
.word,txt
);
        tlen
=strlen(txt
);
        n++;
    }
    qsort(my,n,sizeof(Note),cmp);
    while(scanf("%s",t)!=EOF&&strcmp("#",t)){
        pos=(Note*)bsearch(t,my,n,sizeof(Note),bcmp);
        if(pos)printf("%s is correct\n",pos->word);
        else{
            printf("%s:",t);
            int len=strlen(t);
            for(int i=0;i<n;++i){
                if(len+1==tlen[i]){
                    if(fun2(t,txt[i]))
                    printf(" %s",txt[i]);
                }
                else if(len==tlen[i]){
                    if(fun1(t,txt[i],len))
                    printf(" %s",txt[i]);
                }
                else if(len-1==tlen[i]){
                    if(fun2(txt[i],t))
                    printf(" %s",txt[i]);
                }
            }
            putchar('\n');
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: