您的位置:首页 > 其它

PAT-PAT (Advanced Level) Practise 1008. Elevator (20) (简单模拟)【一星级】

2015-08-19 19:19 435 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1008

题面:

1008. Elevator (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds
to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1

Sample Output:
41


题目大意:上一层花费6s,下一层花费4s,另每层花费5s,问给定的序列,共花费多久。

解题:直接暴力模拟即可。

代码:

#include <cstdio>
int main()
{
	int n,cost=0,a[105];
	scanf("%d",&n);
	a[0]=0;
    for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
	for(int i=1;i<=n;i++)
	{
		if(a[i]-a[i-1]>0)
			cost+=6*(a[i]-a[i-1]);
		else
			cost+=4*(a[i-1]-a[i]);
	}
	cost+=n*5;
	printf("%d\n",cost);
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: