您的位置:首页 > 其它

LA 3026

2015-08-19 17:05 225 查看
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and

126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)

we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be

written as AK, that is A concatenated K times, for some string A. Of course, we also want to know

the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains

N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file

ends with a line, having the number zero on it.

Output

For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for

each prefix with length i that has a period K > 1, output the prefix size i and the period K separated

by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

#define N 1000000 + 10

char s
;
int len;
int next
;

int getNext()
{
    int j, k;
    j = 0; k = -1; next[0] = -1;
    while(j < len)
    if(k == -1 || s[j] == s[k])
    next[++j] = ++k;
    else k = next[k];
}

int main()
{
    int kase = 0;
    while(~scanf("%d", &len) && len)
    {
        scanf("%s", s);
        getNext();
        printf("Test case #%d\n", ++kase);
        for(int i = 2; i <= len; i++)
        {
            if(next[i] > 0 && (i % (i - next[i]) == 0))
            printf("%d %d\n", i, i / (i - next[i]));
        }
        printf("\n");
    }
    return 0;
}

/*

3
aaa
12
aabaabaabaab
0

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: