您的位置:首页 > 其它

LA 3135 Argus (优先队列的简单应用)

2015-08-19 16:45 369 查看
A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor
data, Internet traffic, nancial tickers, on-line auctions, and transaction logs such as Web usage logs
and telephone call records. Likewise, queries over streams run continuously over a period of time and
incrementally return new results as new data arrives. For example, a temperature detection system of
a factory warehouse may run queries like the following.
Query-1: \Every ve minutes, retrieve the maximum temperature over the past ve minutes."
Query-2: \Return the average temperature measured on each
oor over the past 10 minutes."
We have developed a Data Stream Management System called Argus, which processes the queries
over the data streams. Users can register queries to the Argus. Argus will keep the queries running
over the changing data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Register Q num Period
Q num (0 < Qnum  3000) is query ID-number, and Period (0 < Period  3000) is the interval
between two consecutive returns of the result. After Period seconds of register, the result will be
returned for the rst time, and after that, the result will be returned every Period seconds.
Here we have several different queries registered in Argus at once. It is con rmed that all the
queries have different Q num. Your task is to tell the rst K queries to return the results. If two or
more queries are to return the results at the same time, they will return the results one by one in the
ascending order of Q num.
Input
The rst part of the input are the register instructions to Argus, one instruction per line. You can
assume the number of the instructions will not exceed 1000, and all these instructions are executed at
the same time. This part is ended with a line of `#'.
The second part is your task. This part contains only one line, which is one positive integer K
( 10000).
Output
You should output the Q num of the rst K queries to return the results, one number per line.
Sample Input
Register 2004 200
Register 2005 300
#
5
Sample Output

2004
2005
2004
2004
2005

题目大意:

  这道题是说,给你有限个item,item里面有一个num,和一个产生num的周期。现在让你从0时刻开始,连续的产生K个num,产生的时候,必须按照时间先后的原则,如果在某个时间点上能产生几个相同的num,那么就按照num从小到大输出。

解题思路:

  这道题上来后,就想到了优先队列,O(nlogk)的复杂度就可以解决出来。

代码:

# include<cstdio>
# include<iostream>
# include<queue>
# include<algorithm>

using namespace std;

struct node
{
int Qnum,period,cur_time;
bool operator < ( const node & a ) const
{
return a.cur_time<cur_time||(cur_time==a.cur_time&&a.Qnum<Qnum);
}
};

string str;

int main(void)
{
priority_queue<node>pq;
while ( cin>>str )
{
if ( str[0]=='#' )
break;
node item;
scanf("%d%d",&item.Qnum,&item.period);
item.cur_time = item.period;
pq.push(item);
}
int k; scanf("%d",&k);
while ( k-- )
{
node t = pq.top();
pq.pop();
printf("%d\n",t.Qnum);
t.cur_time += t.period;
pq.push(t);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: