您的位置:首页 > 其它

HDU 1075 map解法

2015-08-19 12:37 330 查看
What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 17471 Accepted Submission(s): 5687

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i’m fiwo riwosf.

i fiiwj fnnvk!

END

Sample Output

hello, i’m from mars.

i like earth!

Hint

Huge input, scanf is recommended.

这题可以用字典树做也能用map做,这里放上map解法

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cstdlib>
//#define LOCAL

using namespace std;
char s[1000];
int main()
{
#ifdef LOCAL
freopen("data.in","r",stdin);
#endif // LOCAL
map<string,string>G;
string a,b;
char str1[15],str2[15];
scanf("%s",s);
while(scanf("%s %s\n",str1,str2)&&strcmp(str1, "END")){
a = str1;
b = str2;
G[b] = a;
}
while(gets(s)&&strcmp(s,"END")){
int i,j = 0;
while(s[j]!='\0'){
int k = 0;
for(i = j;s[i]!='\0';i++)
if(s[i]>='a'&&s[i]<='z')
str1[k++] = s[i];
else
break;
str1[k] = '\0';

a = str1;
map<string,string>::iterator it;
it = G.find(a);
if(it!=G.end())
cout << (*it).second;
else
cout << a;
for(j = i;s[j]!='\0';j++)
if(s[j]>='a'&&s[j]<='z')
break;
else
printf("%c",s[j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串 杭电