您的位置:首页 > 其它

Team Formation

2015-08-18 18:37 225 查看
Team FormationTime Limit: 3 Seconds Memory Limit: 131072 KB
For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6


Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest

题意:给定一长度为n的序列,取两数,如果两数异或后的结果大于两数中任意一个,那么称team member,问有多少team member

从n个数中取2个数,问有多少种方法取的两个数的异或大于两个数的最大数
思路:如果x的最高位i位是1,y的位是0,且y比x大,i不是y的最高位,异或后这一位变成1,且yi位以前的1也可以保存,则异或后肯定比两个数的最大值还大

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>

using namespace std;

#define N 100008

int b[32], bit[32]; // b数组存当前数转化成2进制之后的01序列,bit数组存最高位1是当前下标的数有多少。
int num
;

void change(int n)
{
int i = 0;
while(n)
{
b[i++] = n % 2;
n /= 2;
}
}
int main()
{
int t, n, cnt;

scanf("%d", &t);

while(t--)
{
cnt = 0;
memset(bit, 0, sizeof(bit));
scanf("%d", &n);

for(int i = 0; i < n; i++)
scanf("%d", &num[i]);
sort(num, num+n);

int tmp = (int)log2(num[0]);  // 是num[0]转化成二进制,最高位的1在倒数第几位
bit[tmp]++;
for(int i = 1; i < n; i++)
{
int temp = (int)log2(num[i]);
memset(b, 0, sizeof(b));
change(num[i]);

for(int j = 0; j < temp; j++)
{
if(b[j] == 0)
cnt += bit[j];   //只要是最高为1的位,异或后都会增大,所以相加
}
bit[temp]++;  // 更新bit
}
printf("%d\n", cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: