您的位置:首页 > 其它

poj 2251 Dungeon Master 3维bfs(水水)

2015-08-18 16:51 288 查看
Dungeon Master

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21230Accepted: 8261
Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The
input consists of a number of dungeons. Each dungeon description starts
with a line containing three integers L, R and C (all limited to 30 in
size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C
characters. Each character describes one cell of the dungeon. A cell
full of rock is indicated by a '#' and empty cells are represented by a
'.'. Your starting position is indicated by 'S' and the exit by the
letter 'E'. There's a single blank line after each level. Input is
terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!


Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source

Ulm Local 1997
[Submit] [Go Back] [Status] [Discuss]

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
bool vis[100][100][100];
char str[100][100][100];
int step;
int nex[6][3]={0,0,1,0,0,-1,1,0,0,-1,0,0,0,1,0,0,-1,0};
struct node{
int x,y,z;
int dis;
};
node u,v;
int x,y,z;
int bfs(){
// printf("--->%d %d %d\n",u.x,u.y,u.z);
queue<node>q;
q.push(u);
vis[u.z][u.x][u.y]=true;
while(!q.empty()){
u=q.front();
q.pop();
if(str[u.z][u.x][u.y]=='E')
return u.dis;
for(int i=0;i<6;i++){
v.x=u.x+nex[i][1];
v.y=u.y+nex[i][2];
v.z=u.z+nex[i][0];
if(str[v.z][v.x][v.y]!='#'&&!vis[v.z][v.x][v.y]&&v.x>=0&&v.x<x&&v.y>=0&&v.y<y
&&v.z>=0&&v.z<z){
vis[v.z][v.x][v.y]=true;
v.dis=u.dis+1;
q.push(v);
}
}

}
return 0;
}

int main(){

while(scanf("%d%d%d",&z,&x,&y)!=EOF){
if(x==0&&y==0&&z==0)
break;
memset(str,0,sizeof(str));
memset(vis,false,sizeof(vis));
for(int k=0;k<z;k++){
for(int i=0;i<x;i++){
scanf("%s",str[k][i]);
for(int j=0;j<y;j++){
if(str[k][i][j]=='S')
u.x=i,u.y=j,u.z=k,u.dis=0;
}
}
}
step=0;
step=bfs();
if(step>0)
printf("Escaped in %d minute(s).\n",step);
else
printf("Trapped!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: