您的位置:首页 > 其它

排序检索A - Master-Mind Hints

2015-08-18 15:56 274 查看
MasterMind is a game for two players. One of them, Designer, selects a secret code. The other,Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the lengthN
that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code

and a guess


, and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j),

and


, such that

. Match (i,j) is calledstrong when
i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are calledindependent when
i = p if and only if j = q. A set of matches is called
independent when all of its members arepairwise(成对发生的) independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are bothmaximal(最高的).
The hint then consists of the number of strong followed by the number of weak matches inM. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to
the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the
range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum
value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed inparentheses(括号)
and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0


Sample Output

Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

题目很长
输入输出的关系一开始没看懂
第一行的是密码
如果同一列的数字相同的话 输出左+1
如果不同列的数字相同的话  输出右+1且这个数之前没被用过
所以我用了两个数组来标记
输出前面有空格要注意
#include <stdio.h>
#include <string.h>

int main(){
int n, code[1010], guess[1010], times = 1;
while (scanf("%d", &n) != EOF) {
if (n == 0)
break;
printf("Game %d:\n", times++);
memset(code, 0, sizeof(code));
memset(guess, 0, sizeof(guess));
for (int i = 0; i < n; i++)
scanf("%d", &code[i]);
for (;;) {
for (int i = 0; i < n; i++)
scanf("%d", &guess[i]);
int count = 0;
for (int i = 0; i < n; i++)
if(guess[i] == 0)
count++;
if (count == n)
break;

int a = 0, b = 0, mark1[1010], mark2[1010];
memset(mark1, 0, sizeof(mark1));
memset(mark2, 0 , sizeof(mark2));
for (int i = 0; i < n; i++) {
mark1[i] = 1;
mark2[i] = 1;
}
for (int i = 0, j = 0; i < n; i++)
if(guess[i] == code[i]) {
a++;
mark1[i] = 0;
mark2[i] = 0;
}
for (int i = 0; i < n; i++) {
if (mark1[i] == 0)
continue;
for (int j = 0; j < n; j++) {
if (mark2[j] == 0)
continue;
else if (guess[j] == code[i]) {
b++;
mark1[i] = 0;
mark2[j] = 0;
break;
}
}

}
printf("    (%d,%d)\n", a, b);

}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: