您的位置:首页 > 其它

POJ 2318 TOYS(点与凸多边形的位置关系)

2015-08-17 20:09 337 查看
[align=center]TOYS[/align]

Description
Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.



For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is
m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is
at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th
toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that
bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2


【思路分析】
   判断一系列点在哪一个四边形内。这个题和以前做的“HRBUST1429—凸多边形”类似,都是根据该点和多边形某一个边的叉积的正负来判断点和边的位置关系。由于给出的四边形的位置可以在坐标上从左向右排列,所以可以用二分法来提高效率。

代码如下:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 5005

int res[maxn];
struct Point
{
int x;
int y;
};
struct Line
{
Point top,down;
}lines[maxn];

int cross(Point p0,Point p1,Point p2)
{
return (p1.x - p0.x) * (p2.y - p0.y) - (p2.x - p0.x) * (p1.y - p0.y);
}
int main()
{
//freopen("1.txt","r",stdin);
int n,m,x1,y1,x2,y2;
while(scanf("%d",&n) != EOF && n != 0)
{
memset(res,0,sizeof(res));
scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);

lines[0].top.x = x1;
lines[0].top.y = y1;
lines[0].down.x = x1;
lines[0].down.y = y2;
for(int i = 1;i <= n;i++)
{
scanf("%d %d",&lines[i].top.x,&lines[i].down.x);
lines[i].top.y = y1;
lines[i].down.y = y2;
}
lines[n + 1].top.x = x2;
lines[n + 1].top.y = y1;
lines[n + 1].down.x = x2;
lines[n + 1].down.y = y2;

Point p;
while(m--)
{
scanf("%d %d",&p.x,&p.y);
int low = 0;
int high = n + 1;
int mid;
while(low < high)//二分法
{
mid = (low + high) >> 1;
if(cross(lines[mid].top,lines[mid].down,p) > 0)
//叉积为正,点在边向量的逆时针方向,此题中为点在边右侧
low = mid + 1;
else
high = mid;
}
res[low - 1]++;
}

for(int i = 0;i <= n;i++)
{
printf("%d: %d\n",i,res[i]);
}
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: