您的位置:首页 > 其它

POJ2192 Zipper

2015-08-16 14:20 239 查看
Zipper

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17192Accepted: 6115
Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data
set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

Source
Pacific Northwest 2004
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
char stra[210],strb[210],strc[420];
bool dp[420][420];
int main()
{
    int n,i,j;
    int sum=1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s%s%s",stra,strb,strc);
        int lena,lenb;
        lena=strlen(stra);
        lenb=strlen(strb);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        if(stra[0]==strc[0]) dp[1][0]=1;//先判断开头的第一个和哪个相同
        if(strb[0]==strc[0]) dp[0][1]=1;
        for(i=0; i<=lena; i++)//遍历数组,看是第三个数组中的每一个是否有与之前的对应的,记录下每一个坐标下字符的对应情况
        {
            for(j=0; j<=lenb; j++)
            {
                if(i>=1 && strc[i+j-1]==stra[i-1])
                    dp[i][j]=dp[i][j]||dp[i-1][j];//判断它的前一个字符的状态是否是有与之对应的
                if(j>=1 && strc[i+j-1]==strb[j-1] )
                    dp[i][j]=dp[i][j]||dp[i][j-1];
            }
        }
        if(dp[lena][lenb])
            printf("Data set %d: yes\n",sum++);
        else printf("Data set %d: no\n",sum++);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: