您的位置:首页 > 其它

hdu 1150 Machine Schedule 最少点覆盖转化为最大匹配

2015-08-16 09:33 363 查看

Machine Schedule

Time Limit: 1 Sec Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=1150

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

HINT

题意

一项任务能在两个机器的状态a和b中一个完成,两个机器分别有n,m中状态,问k项任务做多能最少在转换多少次状态下完成;

题解:

把A机器的n个状态和B的m个状态看作顶点,如果任务1能在状态Ai和状态Bi下完成则在Ai--Bi间连一条边这样构造一个二部图
本题就是求二部图的最小点覆盖问题即求最小的顶点集合覆盖所有边,须知 二部图的点覆盖数=匹配数题解
代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <queue>
#include <typeinfo>
#include <map>
#include <stack>
typedef long long ll;
#define inf 0x7fffffff
using namespace std;
inline ll read()
{
ll x=0,f=1;
char ch=getchar();
while(ch<'0'||ch>'9')
{
if(ch=='-')f=-1;
ch=getchar();
}
while(ch>='0'&&ch<='9')
{
x=x*10+ch-'0';
ch=getchar();
}
return x*f;
}
//*************************************************
int n,m;
int lk[500];
int g[105][105];
int y[500];
int ans;
bool dfs(int v)
{
for(int i=1;i<=m;i++){
if(g[v][i]&&!y[i])
{
y[i]=1;
if(lk[i]==0||dfs(lk[i]))
{
lk[i]=v;
return 1;
}
}
}
return 0;
}
void solve()
{
for(int i=1;i<=n;i++)
{
memset(y,0,sizeof(y));
ans+=dfs(i);
}
cout<<ans<<endl;
}
int main()
{
int k;
while(cin>>n)
{
if(n==0)break;
cin>>m>>k;
ans=0;
memset(g,0,sizeof(g));
memset(lk,0,sizeof(lk));
int x,a,b;
for(int i=1;i<=k;i++){cin>>x>>a>>b;g[a][b]=1;}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: