您的位置:首页 > 其它

Wormholes

2015-08-15 16:49 141 查看
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,
M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to
F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N,
M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: a bidirectional path between
S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: A one way path from S to
E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题解:判断是否有负环。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define mem(a) memset(a,0,sizeof(a));

using namespace std;

const int INF = 0x3fffffff;

struct Node
{
int from;
int to;
int time;
};

Node e[5505];
int d[550];

bool bellman(int n,int edge)
{
for(int i = 1;i <= n;i++)
{
d[i] = INF;
}
d[1] = 0; //找个起点
bool flag;
for(int i = 1;i <= n;i++)
{
flag = false;
for(int j = 0;j < edge;j++)
{
if(d[e[j].to] > d[e[j].from] + e[j].time)
{
flag = true;
d[e[j].to] = d[e[j].from] + e[j].time;
}
}
if(!flag)
{
return false;
}
if(i == n)
{
return true;
}
}

}

int main()
{
int T;
cin>>T;
while(T--)
{
int n,m,w;
int k = 0;
scanf("%d%d%d",&n,&m,&w);
for(int i = 0;i < m;i++)
{
int u,v,c;
scanf("%d%d%d",&u,&v,&c);
e[k].from = u;
e[k].to = v;
e[k++].time = c;
e[k].from = v;
e[k].to = u;
e[k++].time = c;
}
for(int i = 0;i < w;i+
4000
+)
{
int u,v,c;
scanf("%d%d%d",&u,&v,&c);
e[k].from = u;
e[k].to = v;
e[k++].time = -c;
}

if(bellman(n,k))
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: